Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 07, 2025 - 09:00 UTC
Scheduled
On Thursday, August 7 at 09:00 UTC, we will perform maintenance on the WordPress Application Servers located in the US-West (Santa Clara, US) datacenter.
During maintenance, brief interruptions may be experienced, potentially impacting uncached content.
Posted Aug 06, 2025 - 09:35 UTC
This scheduled maintenance affected: Pressidium Services (WordPress Application Servers) and Pressidium Regions (US-West (Santa Clara / US)).