Emergency Maintenance: Pressidium Services – Singapore Data Center

Incident Report for Pressidium® Cloud Status

Resolved

The maintenance has been completed.
Posted Sep 18, 2026 - 20:28 UTC

Identified

Emergency maintenance is currently being performed on Pressidium services in the Singapore region.

During this maintenance, the following are temporarily unavailable:
- Pressidium API
- Backup creation
- Cache purging
- Staging site creation

There is no impact on websites and visitors.
Expected maintenance duration: 5 minutes.
Posted Sep 18, 2026 - 20:21 UTC
This incident affected: Pressidium Services (Staging & Snapshots, Cloud Backups, API) and Pressidium Regions (OC-West (Singapore / SG)).