The Pressidium API and Dashboard have remained stable, and we’re confident this matter has been resolved. If you are still experiencing issues, please contact our Support Team for assistance.
Posted Dec 21, 2025 - 20:27 UTC
Monitoring
We have corrected the issues affecting Pressidium API and Pressidium Dashboard. We will continue to monitor the situation for any further problems. If you are still experiencing connectivity issues, please reach out to our Support Team for assistance.
Posted Dec 21, 2025 - 19:24 UTC
Investigating
Pressidium API and Pressidium Dashboard is currently undergoing emergency maintenance.
The Pressidium Dashboard and the Pressidium API will experience interruptions. There will be no impact on websites and visitors.