Emergency Network Maintenance at C20 cluster

Incident Report for Pressidium® Cloud Status

Resolved

No further issues have been detected, all services are operational.
Posted Dec 17, 2025 - 04:41 UTC

Monitoring

The emergency maintenance has been completed. We will continue to monitor the situation for any further problems. If you are still experiencing connectivity issues, please reach out to our Support Team for assistance.
Posted Dec 16, 2025 - 19:36 UTC

Update

We are continuing to investigate this issue.
Posted Dec 16, 2025 - 17:30 UTC

Investigating

C20 cluster is currently undergoing emergency maintenance. Due to the maintenance, site-wide network interruptions and connectivity issues are experienced by websites hosted in this datacenter.
Our network engineering team is working with our upstream provider to get these issues resolved as soon as possible.
Posted Dec 16, 2025 - 17:27 UTC
This incident affected: Pressidium Services (Firewalls, WebApp Firewalls, Load Balancers, Multilayer Caching, WordPress Application Servers).