Emergency Network Maintenance at EU-West Datacenter

Incident Report for Pressidium® Cloud Status

Resolved

After monitoring systems for a while, no issues have been observed.
Posted Aug 05, 2025 - 11:45 UTC

Monitoring

Emergency maintenance has concluded, and we are now actively monitoring the system to ensure continued stability.
Posted Aug 05, 2025 - 07:50 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 05, 2025 - 06:52 UTC

Identified

Emergency maintenance is ongoing, and an additional fix has been deployed. During this time, websites hosted in this datacenter may experience network interruptions and connectivity issues.
Posted Aug 05, 2025 - 06:52 UTC

Monitoring

Emergency maintenance has been completed, and we are now monitoring the system for stability.
Posted Aug 05, 2025 - 05:52 UTC

Investigating

Our EU-West Datacenter is currently undergoing emergency maintenance. Due to the maintenance, site-wide network interruptions and connectivity issues are experienced by websites hosted in this datacenter.
Posted Aug 05, 2025 - 05:31 UTC
This incident affected: Pressidium Regions (EU-West (London / UK)).