The emergency maintenance on our C8 cluster has been completed, and affected services have been restored. We are currently monitoring the cluster closely to confirm continued stability following the maintenance.
Posted Jul 20, 2026 - 23:56 UTC
Identified
Our C8 cluster is currently undergoing emergency maintenance. Due to the maintenance, websites hosted on this cluster may experience intermittent availability for dynamic (uncached) requests, while certain management operations (such as updates, migrations, and backup-related tasks) may also be temporarily unavailable.
Our engineering team is working to complete the maintenance and restore full service as quickly as possible.
Posted Jul 20, 2026 - 22:34 UTC
This incident affected: Pressidium Regions (EU-West (London / UK)) and Pressidium Services (WordPress Application Servers, SFTP, Staging & Snapshots).