US-EAST-2 (Ashburn) Datacenter has remained stable, and we're confident this matter has been resolved. If you are still experiencing issues, please contact our Support Team for assistance.
Posted Aug 02, 2025 - 07:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 19:34 UTC
Investigating
Our US-EAST-2 (Ashburn) Datacenter is currently undergoing emergency maintenance. Due to the maintenance, site-wide network interruptions and connectivity issues are experienced by websites hosted in this datacenter. Our network engineering team is working with our upstream provider to get these issues resolved as soon as possible.