Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 05, 2025 - 06:00 UTC
Scheduled
We will perform maintenance on servers in the Newark, Ashburn, and São Paulo datacenters on 5/12/2025 between 06:00 and 10:00 UTC. Short service interruptions may occur during this window.
Posted Dec 04, 2025 - 10:11 UTC
This scheduled maintenance affected: Pressidium Regions (US-East (Newark / US), US-East (Ashburn / US), SA-Saopaulo (Sao Paulo / Brazil)).