The issue affecting our upstream's provider datacenter has been fully resolved.
All clusters and systems within the affected datacenter, continue to perform stably and normally.
Posted Jul 29, 2025 - 06:56 UTC
Monitoring
At this time, all clusters and systems within the affected datacenter are back online, and all websites are fully operational.
We will continue to monitor the situation closely and share any relevant updates as needed.
Posted Jul 28, 2025 - 14:02 UTC
Identified
The issue has been identified as a failure of the HVAC (Heating, Ventilation, and Air Conditioning) system at our upstream provider’s datacenter in Newark. These systems are critical for maintaining proper temperature and airflow within the facility, and their failure has impacted both internal infrastructure and customer-facing services. The upstream provider’s team has been working on-site around the clock to restore full functionality.
At this time possible website restorations from offsite backups are under consideration, to standby clusters located in a completely different datacenter, as an emergency solution so that the website functionality can be restored.
We will continue to provide updates as progress is made.
Posted Jul 28, 2025 - 09:14 UTC
Update
We are continuing to investigate this issue.
Posted Jul 27, 2025 - 10:34 UTC
Investigating
Our Newark Datacenter is currently undergoing emergency maintenance. Due to the maintenance, site-wide network interruptions and connectivity issues are experienced by websites hosted in this datacenter. Our network engineering team is working with our upstream provider to get these issues resolved as soon as possible.